CVE-2026-27820: Jruby · Versions 3.0.0 and below, 3.1.0, 3.1.1, 3.2.0 and 3.2.1 contain a buffer overflow
Affects jrubySource GCVE Database
Not known to be exploited · CVSS 1.7 Low : upgrade to 2.3.1-2~ubuntu16.04.16+esm15 when convenient.
Data as of 6 Nov 2026, 15:39 UTC
- Patch
- Available – fixed in 2.3.1-2~ubuntu16.04.16+esm15
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:UExploitation evidence
Disclosed: evidence found.
CVE published 16 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.
What to do
Upgrade the Ubuntu ruby2.3 package to 2.3.1-2~ubuntu16.04.16+esm15.
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.10jrubypkg:deb/ubuntu/jruby?arch=source&distro=stonkingOther threats | Affected
| Fixed in– |
Ubuntu 26.10ruby3.3pkg:deb/ubuntu/ruby3.3?arch=source&distro=stonkingOther threats | Affected
| Fixed in– |
Ubuntu 26.04 LTSruby3.3pkg:deb/ubuntu/ruby3.3?arch=source&distro=resoluteOther threats | Affected
| Fixed in– |
Ubuntu 25.10jrubypkg:deb/ubuntu/jruby?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Ubuntu 25.10ruby3.3pkg:deb/ubuntu/ruby3.3?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Ubuntu 24.04 LTSruby3.2pkg:deb/ubuntu/ruby3.2?arch=source&distro=nobleOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available and should be applied promptly. Users should update to the fixed versions: 3.0.1, 3.1.2, or 3.2.3 of jruby or the corresponding patched package versions such as libruby2.3 version 2.3.1-2~ubuntu16.04.16+esm15 on Ubuntu 16.04 LTS. Standard system updates will apply the necessary patches. No additional mitigation steps are required beyond applying the official updates.
Description
A buffer overflow vulnerability exists in the Zlib::GzipReader component of the Ruby interface for the zlib compression library (jruby). This flaw occurs because the zstream_buffer_ungets function does not ensure the backing Ruby string has sufficient capacity before shifting data, leading to potential memory corruption. The issue affects multiple versions of jruby including 3.0.0 and below, 3.1.0, 3.1.1, 3.2.0, and 3.2.1. It has been fixed in versions 3.0.1, 3.1.2, and 3.2.3. The vulnerability has a critical severity with a CVSS score of 9.8.