Skip to main content
CVE-2026-122234VulnerabilityPublished

jsondiffpatch before 0.7.7 contains a cross-site scripting vulnerability that allows attackers to inject markup by

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-122234· Low 2.3

Not known to be exploited · CVSS 2.3 Low : upgrade to 0.7.7 when convenient.

Data as of 4 Nov 2026, 22:39 UTC

CVSS 4.0 base score
2.3Low
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.02.3
CNA (VulnCheck)CVSS 3.14.7
Patch
Available – fixed in 0.7.7
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade jsondiffpatch to 0.7.7.

Affected software

ProductAffectedFixed in
benjaminejsondiffpatchAffected
  • <0.7.7
Fixed in
  • 0.7.7
npmjsondiffpatchpkg:npm/jsondiffpatchOther threatsAffected
  • <0.7.7
Fixed in
  • 0.7.7

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in jsondiffpatch version 0.7.7 and later. Users should upgrade to version 0.7.7 or newer to remediate this vulnerability. No vendor advisory content was provided, but the version-based fix is clearly stated. No additional mitigations are indicated.

Description

jsondiffpatch versions before 0.7.7 have a cross-site scripting (XSS) vulnerability. This flaw allows attackers to inject malicious markup by providing an unescaped array-move destination index in a delta. If an attacker controls the delta passed to the formatters.html.format() or formatters.annotated.format() functions, they can embed scripts that execute in the context of the application's origin when the output is rendered.

References

Community reviews

Loading reviews…