CVE-2026-35571: Gov.nsa.emissary:emissary: Emissary has Stored XSS via Navigation Template Link Injection
Affects gov.nsa.emissary:emissarySource GCVE Database
Not known to be exploited · CVSS 4.8 Medium : upgrade to 8.39.0 when convenient.
Data as of 4 Nov 2026, 23:29 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 7% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 8.39.0
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 7 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.
What to do
Upgrade gov.nsa.emissary:emissary to 8.39.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Mavengov.nsa.emissary:emissary | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Emissary to version 8.39.0 or later, which includes server-side validation of navigation links to allow only http://, https://, or relative URLs, and template hardening with rel="noopener noreferrer" attributes. If immediate upgrade is not possible, audit the navigation configuration to ensure all navItems links use only allowed URL schemes (http://, https://, or relative paths).
Description
Emissary versions prior to 8.39.0 contain a stored cross-site scripting (XSS) vulnerability in the navigation template. The vulnerability arises because navigation link URLs are interpolated into href attributes without validating the URL scheme, allowing an administrator to inject javascript: URIs. Authenticated users who click such malicious links can execute arbitrary scripts in their browser context, potentially leading to session hijacking and actions performed on their behalf. Exploitation requires administrative access to modify navigation configuration and user interaction. The issue is fixed in version 8.39.0 by adding server-side URL scheme validation and template hardening.
References
- github.com/NationalSecurityAgency/emissary/security/advisories/GHSA-cpm7-cfpx-3hvp (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-35571 (opens in a new tab)
- github.com/NationalSecurityAgency/emissary/pull/1293 (opens in a new tab)
- github.com/NationalSecurityAgency/emissary/commit/e2078417464b9004620dde28dcbca2f73ea06c13 (opens in a new tab)
- github.com/NationalSecurityAgency/emissary (opens in a new tab)
- github.com/NationalSecurityAgency/emissary/releases/tag/8.39.0 (opens in a new tab)