CVE-2025-43859: Jupyterlab · h11 accepts some malformed Chunked-Encoding bodies
Affects jupyterlabSource GCVE Database
Not known to be exploited · CVSS 9.1 Critical : upgrade to 4.4.1_1 as a priority.
Data as of 30 Oct 2026, 09:14 UTC
- Patch
- Available – fixed in 4.4.1_1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 13 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade jupyterlab to 4.4.1_1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewjupyterlabpkg:brew/jupyterlabOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available in JupyterLab version 4.4.1_1, which includes h11 0.15.0 that fixes the parsing issue. Applying this update fully mitigates the vulnerability. Alternatively, fixing the reverse proxy to correctly parse chunked encoding also mitigates the risk. Since exploitation requires both components to be vulnerable, remediating either side is sufficient.
Description
CVE-2025-43859 is a critical vulnerability in h11's handling of HTTP/1.1 chunked transfer encoding, affecting JupyterLab versions >=4.1.0 and <4.4.1_1. The flaw arises because h11 accepts malformed chunked-encoding bodies by not strictly validating the trailing CRLF bytes after each chunk. This leniency can lead to HTTP request smuggling when combined with a buggy reverse proxy that parses chunked bodies differently. Exploitation could allow attackers to bypass proxy protections or cause session key leakage between users. The issue is fixed in h11 version 0.15.0 and JupyterLab 4.4.1_1.
References
- github.com/python-hyper/h11/security/advisories/GHSA-vqfr-h8mv-ghfj (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2025-43859 (opens in a new tab)
- github.com/python-hyper/h11/commit/114803a29ce50116dc47951c690ad4892b1a36ed (opens in a new tab)
- github.com/pypa/advisory-database/tree/main/vulns/h11/PYSEC-2026-348.yaml (opens in a new tab)
- github.com/python-hyper/h11 (opens in a new tab)
- pypi.org/project/h11 (opens in a new tab)