Skip to main content
CVE-2026-91990VulnerabilityPublished Updated

jupyterlab · tornado: multipart split() creates huge temp list before max_parts check -> memory amplification DoS (httputil.py:34)

Affects jupyterlabSource GCVE Database

0
Compare
Authoritative record:CVE-2026-91990· High 8.7

Not known to be exploited · CVSS 8.7 High : upgrade to 4.6.3 soon.

Data as of 30 Oct 2026, 08:47 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 4.6.3
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 15 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade jupyterlab to 4.6.3.

Affected software

ProductAffectedFixed in
Homebrewjupyterlabpkg:brew/jupyterlabOther threatsAffected
  • >=1.2.0 <4.6.3
Fixed in
  • 4.6.3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and included in JupyterLab version 4.6.3. Users should upgrade to version 4.6.3 or later to remediate this vulnerability. No additional mitigation is required if the patch is applied.

Description

A vulnerability in JupyterLab's multipart form data parsing allows an attacker to cause a denial of service (DoS) by triggering excessive memory usage. The function parse_multipart_form_data splits the input data into a large list before checking the number of parts, leading to transient memory amplification. This can be exploited pre-authentication by sending a crafted HTTP request with many parts, causing high memory consumption and potential service disruption. The issue affects versions from 1.2.0 up to but not including 4.6.3 and has been fixed in version 4.6.3.

References

Community reviews

Loading reviews…