CVE-2026-44896: Jupyterlab · Mistune has XSS via unescaped figclass/figwidth in Figure directive
Affects jupyterlabSource GCVE Database
Not known to be exploited · CVSS 5.3 Medium : upgrade to 4.5.7_1 when convenient.
Data as of 30 Oct 2026, 09:14 UTC
- Patch
- Available – fixed in 4.5.7_1
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 26 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade jupyterlab to 4.5.7_1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewjupyterlabpkg:brew/jupyterlabOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available in JupyterLab version 4.5.7_1 that fixes this vulnerability by properly escaping the figclass and figwidth options in the render_figure() function. Users should upgrade to version 4.5.7_1 or later to remediate this issue. No other mitigations are specified or required.
Description
CVE-2026-44896 is a cross-site scripting (XSS) vulnerability in JupyterLab's Mistune markdown renderer. The flaw occurs because the render_figure() function in src/mistune/directives/image.py inserts figclass and figwidth options directly into HTML attributes without escaping, allowing attribute injection. This bypasses the usual HTML escaping protections even when HTMLRenderer(escape=True) is used. Other attributes like src, alt, and style are properly escaped. The vulnerability affects JupyterLab versions from 1.2.0 up to but not including 4.5.7_1.
References
- github.com/lepture/mistune/security/advisories/GHSA-58cw-g322-p94v (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-44896 (opens in a new tab)
- github.com/lepture/mistune/commit/a3cb6e5655308797e8be021d6c7b5bab13cbace2 (opens in a new tab)
- github.com/lepture/mistune (opens in a new tab)
- github.com/pypa/advisory-database/tree/main/vulns/mistune/PYSEC-2026-168.yaml (opens in a new tab)