CVE-2026-44708: Jupyterlab · Mistune Math Plugin has an XSS Escape Bypass
Affects jupyterlabSource GCVE Database
Not known to be exploited · CVSS 6.1 Medium : upgrade to 4.5.7_1 when convenient.
Data as of 30 Oct 2026, 09:15 UTC
- Patch
- Available – fixed in 4.5.7_1
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 26 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade jupyterlab to 4.5.7_1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewjupyterlabpkg:brew/jupyterlabOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available in JupyterLab version 4.5.7_1 that fixes this vulnerability. Users should upgrade to version 4.5.7_1 or later to mitigate the issue. Until upgraded, avoid enabling or using the Mistune math plugin with untrusted user input or disable math rendering in markdown if possible.
Description
The Mistune math plugin used in JupyterLab versions >=1.2.0 and <4.5.7_1 has a cross-site scripting (XSS) vulnerability due to improper escaping of user-supplied content inside math delimiters ($...$ and $$...$$). This allows raw HTML and script tags to be injected and executed in the browser, bypassing the expected escape mechanism. A fix is available in version 4.5.7_1.