CVE-2026-44898: Jupyterlab · Mistune TOC Anchor Injection XSS
Affects jupyterlabSource GCVE Database
Not known to be exploited · CVSS 6.1 Medium : upgrade to 4.5.7_1 when convenient.
Data as of 30 Oct 2026, 09:14 UTC
- Patch
- Available – fixed in 4.5.7_1
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 26 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade jupyterlab to 4.5.7_1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewjupyterlabpkg:brew/jupyterlabOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available in JupyterLab version 4.5.7_1 that properly escapes heading IDs before inserting them into the TOC href attributes. Users and administrators should upgrade affected JupyterLab installations to version 4.5.7_1 or later to remediate this vulnerability. No additional mitigation steps are required if the patch is applied.
Description
JupyterLab's use of Mistune's render_toc_ul() function allows unescaped user-supplied heading IDs to be injected directly into HTML anchor href attributes. This leads to a cross-site scripting (XSS) vulnerability when heading IDs are derived from user input without proper escaping. An attacker can craft headings that break out of the href attribute context and inject arbitrary HTML, including script tags, into the table of contents. This vulnerability affects versions from 1.2.0 up to but not including 4.5.7_1 and has been assigned CVE-2026-44898. A fix is available in version 4.5.7_1.
References
- github.com/lepture/mistune/security/advisories/GHSA-6269-cqxg-mhhv (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-44898 (opens in a new tab)
- github.com/lepture/mistune/commit/04880a0 (opens in a new tab)
- github.com/lepture/mistune (opens in a new tab)
- github.com/lepture/mistune/releases/tag/v3.2.1 (opens in a new tab)