CVE-2026-49854: Jupyterlab · Tornado has out-of-bounds memory access via C extension
Affects jupyterlabSource GCVE Database
Not known to be exploited · CVSS 5.3 Medium : upgrade to 4.5.8 when convenient.
Data as of 30 Oct 2026, 08:59 UTC
- Patch
- Available – fixed in 4.5.8
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 14 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade jupyterlab to 4.5.8.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewjupyterlabpkg:brew/jupyterlabOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Tornado to version 4.5.8 or later to apply the official fix. As a temporary mitigation before upgrading, set the environment variable TORNADO_EXTENSION=0 to disable the vulnerable native extension code, noting that this will reduce websocket performance.
Description
A vulnerability in Tornado's native extension used by JupyterLab allows out-of-bounds memory access due to improper validation of the mask argument length in the websocket_mask function. This flaw can expose up to 3 bytes of uninitialized memory. The issue occurs when Tornado's XSRF token decoder is used with xsrf_cookies enabled and the native extension active. The vulnerability is fixed in Tornado version 4.5.8.