CVE-2025-47287: Jupyterlab · Tornado vulnerable to excessive logging caused by malformed multipart form data
Affects jupyterlabSource GCVE Database
Not known to be exploited · CVSS 7.5 High : upgrade to 4.4.2_1 soon.
Data as of 30 Oct 2026, 09:00 UTC
- Patch
- Available – fixed in 4.4.2_1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 13 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade jupyterlab to 4.4.2_1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewjupyterlabpkg:brew/jupyterlabOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Tornado to version 6.5 or later to fully remediate the vulnerability. Until the upgrade can be applied, mitigate risk by blocking HTTP requests with the Content-Type header set to multipart/form-data at a proxy or firewall to prevent exploitation.
Description
A denial-of-service vulnerability exists in Tornado's multipart/form-data parser used by JupyterLab. When encountering malformed multipart form data, Tornado logs warnings synchronously while continuing to parse, allowing remote attackers to generate excessive logs and cause a DoS. All Tornado versions prior to 6.5 are affected. The issue is fixed in Tornado 6.5 and later. Mitigation before upgrading includes blocking multipart/form-data content types at a proxy.
References
- github.com/tornadoweb/tornado/security/advisories/GHSA-7cx3-6m66-7c5m (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2025-47287 (opens in a new tab)
- github.com/tornadoweb/tornado/commit/b39b892bf78fe8fea01dd45199aa88307e7162f3 (opens in a new tab)
- github.com/tornadoweb/tornado (opens in a new tab)
- lists.debian.org/debian-lts-announce/2025/05/msg00038.html (opens in a new tab)