CVE-2025-67724: Jupyterlab · Tornado vulnerable to Header Injection and XSS via reason argument
Affects jupyterlabSource GCVE Database
Not known to be exploited · CVSS 5.4 Medium : upgrade to 4.5.1 when convenient.
Data as of 30 Oct 2026, 09:00 UTC
- Patch
- Available – fixed in 4.5.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 12 Dec 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade jupyterlab to 4.5.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewjupyterlabpkg:brew/jupyterlabOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade JupyterLab to version 4.5.1 or later, which includes Tornado 6.5.3 or newer where the vulnerability is fixed. Alternatively, avoid passing untrusted input to the 'reason' argument in HTTPError or set_status calls. Since the 'reason' argument is rarely required and not used in HTTP/2, it can generally be omitted. For general-purpose error messages, use the 'log_message' argument instead of 'reason'.
Description
JupyterLab versions from 1.2.0 up to but not including 4.5.1 are affected by a vulnerability in the Tornado web framework (CVE-2025-67724) where the 'reason' argument used in HTTP status responses can lead to header injection or reflected cross-site scripting (XSS). This occurs if untrusted input is passed to the 'reason' argument, which is then included unescaped in HTTP headers or the default error page HTML. The vulnerability allows remote attackers to execute arbitrary JavaScript in users' browsers when they view the error page. The issue is fixed in Tornado 6.5.3 and JupyterLab 4.5.1. Mitigation includes upgrading to fixed versions or avoiding use of untrusted data in the 'reason' argument.
References
- github.com/tornadoweb/tornado/security/advisories/GHSA-pr2v-jx2c-wg9f (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2025-67724 (opens in a new tab)
- github.com/tornadoweb/tornado/commit/9c163aebeaad9e6e7d28bac1f33580eb00b0e421 (opens in a new tab)
- github.com/pypa/advisory-database/tree/main/vulns/tornado/PYSEC-2025-265.yaml (opens in a new tab)
- github.com/tornadoweb/tornado (opens in a new tab)
- github.com/tornadoweb/tornado/releases/tag/v6.5.3 (opens in a new tab)