Skip to main content
CVE-2024-37285VulnerabilityPublished Updated

CVE-2024-37285: Kibana arbitrary code execution via YAML deserialization

Affects kibanaSource GCVE Database

0

Not known to be exploited : upgrade to 8.15.1 as a priority.

Data as of 26 Oct 2026, 06:26 UTC

Severity
Critical

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
1.2% chance of exploitation in 30 days – higher than 69% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 8.15.1

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 16 Nov 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade kibana to 8.15.1.

Affected software

ProductAffectedFixed in
Bitnamikibanapkg:bitnami/kibanaOther threatsAffected
  • >=8.10.0 <8.15.1
Fixed in
  • 8.15.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available for this vulnerability. Users should upgrade Kibana to a fixed version at or beyond 8.15.1. Restricting privileges to prevent users from having the required combination of Elasticsearch indices and Kibana permissions can also mitigate risk. Follow vendor guidance for applying the official fix.

Description

A deserialization vulnerability in Kibana allows arbitrary code execution when parsing a maliciously crafted YAML document. Exploitation requires a user to have specific Elasticsearch indices privileges (write on .kibana_ingest system indices with allow_restricted_indices set to true) combined with certain Kibana privileges under Fleet or Integration, or access via the Fleet Server’s service account token. The affected Kibana versions are from 8.10.0 up to but not including 8.15.1. This vulnerability is rated critical due to the potential for arbitrary code execution. A patch is available to address this issue.

References

Community reviews

Loading reviews…