CVE-2026-28498: Authlib · Fail-Open Cryptographic Verification in OIDC Hash Binding
Affects kimi-cliSource GCVE Database
Not known to be exploited · CVSS 8.2 High : upgrade to 1.17.0 soon.
Data as of 2 Nov 2026, 10:58 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 14% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.17.0
CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 13 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.
What to do
Upgrade kimi-cli to 1.17.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewkimi-clipkg:brew/kimi-cliOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available for this vulnerability. Users of kimi-cli versions >=0.40 and <1.17.0 should upgrade to a fixed version that enforces fail-closed behavior on unsupported cryptographic algorithms in OIDC token verification. Applying the official patch eliminates the risk of token substitution attacks caused by this flaw.
Description
A critical vulnerability (CVE-2026-28498) exists in the Authlib Python library used by kimi-cli that allows bypassing cryptographic verification of OIDC ID Token hash claims. The flaw causes the library to incorrectly accept tokens with unsupported cryptographic algorithms by returning a successful validation result instead of failing. This enables token substitution attacks in OIDC Hybrid or Implicit flows, violating OpenID Connect and JWT specifications. A patch is available that enforces fail-closed behavior on unsupported algorithms.
References
- github.com/authlib/authlib/security/advisories/GHSA-m344-f55w-2m6j (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-28498 (opens in a new tab)
- github.com/authlib/authlib/commit/b9bb2b25bf8b7e01512d847a95c1749646eaa72b (opens in a new tab)
- github.com/authlib/authlib (opens in a new tab)
- github.com/authlib/authlib/releases/tag/v1.6.9 (opens in a new tab)