CVE-2026-110857: Kimi cli · GitPython command wrappers omit unsafe protocol and option checks
Affects kimi-cliSource GCVE Database
Not known to be exploited · CVSS 7.7 High : upgrade to 1.50.0 soon.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 35% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.50.0
CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 14 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade kimi-cli to 1.50.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewkimi-clipkg:brew/kimi-cliOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available in Kimi CLI version 1.50.0 that adds the missing unsafe protocol and option checks to the affected methods. Users should upgrade to version 1.50.0 or later to remediate this vulnerability. Until patched, ensure that git transport policies disallow unsafe protocols such as 'ext' (default in git >= 2.38.1) to reduce exposure. No other immediate mitigations are indicated by the vendor advisory.
Description
Kimi CLI's GitPython command wrappers omit critical checks for unsafe protocols and options in three methods: Git.ls_remote, Repo.merge_base, and IndexFile.move. This omission allows potential remote code execution (RCE) via the 'ext::' transport protocol if the victim's git configuration permits it, particularly in environments with git versions prior to 2.38.1. The vulnerability is confirmed on the main branch post the latest release and affects versions from 1.11.0 up to but not including 1.50.0. A patch is available in version 1.50.0.
References
- github.com/gitpython-developers/GitPython/security/advisories/GHSA-w8jc-g24h-crhw (opens in a new tab)
- github.com/gitpython-developers/GitPython/pull/2251 (opens in a new tab)
- github.com/gitpython-developers/GitPython/commit/9ad28cc4c7176d22cd6181d69805058a719dd03b (opens in a new tab)
- github.com/gitpython-developers/GitPython (opens in a new tab)
- github.com/gitpython-developers/GitPython/releases/tag/3.2.0 (opens in a new tab)