Skip to main content
CVE-2026-42137VulnerabilityPublished

getkirby/cms · Kirby CMS's `pages.access/list` and `files.access/list` permissions are not consistently checked in the Panel and REST

Affects getkirby/cmsSource GCVE Database

0
Authoritative record:CVE-2026-42137· High 7.1

Not known to be exploited · CVSS 7.1 High : upgrade to 4.9.0 soon.

Data as of 27 Oct 2026, 00:31 UTC

CVSS 4.0 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 4.9.0, 5.4.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 9 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade getkirby/cms to 4.9.0; getkirby/cms to 5.4.0.

Affected software

ProductAffectedFixed in
Packagistgetkirby/cmsAffected
  • <4.9.0
Fixed in
  • 4.9.0
Packagistgetkirby/cmsAffected
  • >=5.0.0 <5.4.0
Fixed in
  • 5.4.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Update Kirby CMS to version 4.9.0, 5.4.0, or any later release to apply the official fix. These versions include consistent permission checks enforcing the `pages.access`, `pages.list`, `files.access`, and `files.list` permissions. No additional mitigation is required once patched.

Description

Kirby CMS versions prior to 4.9.0 and versions from 5.0.0 up to but not including 5.4.0 have inconsistent enforcement of the `pages.access/list` and `files.access/list` permissions in the Panel and REST API. Authenticated users with roles that lack these permissions may still see or access pages and files they should not. This vulnerability does not affect write actions and only impacts sites where access restrictions are configured. The issue has been fixed in Kirby 4.9.0 and 5.4.0.

References

Community reviews

Loading reviews…