Kirki plugin for WordPress before 6.4.1 contains a broken object-level access control vulnerability in its page REST
Source GCVE Database
Not known to be exploited · CVSS 7.2 High : upgrade to 6.4.1 soon.
Data as of 30 Oct 2026, 16:50 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 7.2 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 7.6 |
- Patch
- Available – fixed in 6.4.1
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:H/VA:L/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 30 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade Kirki (WordPress plugin) to 6.4.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| ThemeumKirki | Affected
| Fixed in
|
AI-suggested
If you cannot patch yet, restrict Kirki edit access to trusted users only and monitor for unusual content modifications.
Description
The Kirki plugin for WordPress versions prior to 6.4.1 has a broken object-level access control vulnerability in its page REST API. This flaw allows users with Kirki edit access, typically granted to the Editor role, to modify titles, slugs, and publication statuses of any non-trashed post, including custom post types and WooCommerce products they do not own. The vulnerability arises because the API relies only on a coarse role-based access check without verifying per-object WordPress capabilities. Exploitation can expose private or draft content or remove published content by manipulating the post_status field.