Skip to main content
CVE-2026-122307VulnerabilityPublished

Kyverno before 1.19.2 contains a policy bypass vulnerability in the admissionpolicygenerator controller, which folds

Affects kyvernoSource GCVE Database

0
Compare
Authoritative record:CVE-2026-122307· High 8.3

Not known to be exploited · CVSS 8.3 High : upgrade to 1.19.2 soon.

Data as of 5 Nov 2026, 04:27 UTC

CVSS 4.0 base score
8.3High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.08.3
CNA (VulnCheck)CVSS 3.17.7
Patch
Available – fixed in 1.19.2
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:N/SC:N/SI:H/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 5 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade kyverno/kyverno to 1.19.2.

Affected software

ProductAffectedFixed in
GitHubkyverno/kyvernopkg:github/kyverno/kyvernoOther threatsAffected
  • <1.19.2
Fixed in
  • 1.19.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Kyverno to version 1.19.2 or later, where this vulnerability is fixed. No alternative mitigations are indicated.

Description

Kyverno versions prior to 1.19.2 have a policy bypass vulnerability in the admissionpolicygenerator controller. This flaw allows users with namespaced create rights on PolicyExceptions to inject negated matchConditions into generated ValidatingAdmissionPolicies, bypassing cluster-wide policy enforcement. The vulnerability arises because the controller folds PolicyExceptions into generated policies while ignoring certain gates like --enablePolicyException, --exceptionNamespace, and policy kind gates.

References

Community reviews

Loading reviews…