Skip to main content
CVE-2026-23881VulnerabilityPublished Updated

CVE-2026-23881: Kyverno Denial of Service via Context Variable Amplification in Policy Engine

Affects kyvernoSource GCVE Database

0

Not known to be exploited : upgrade to 1.16.3 or 1.15.3 soon.

Data as of 25 Oct 2026, 19:02 UTC

Severity
High

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.6% chance of exploitation in 30 days – higher than 49% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.16.3, 1.15.3

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade kyverno to 1.16.3 or 1.15.3.

Affected software

ProductAffectedFixed in
Bitnamikyvernopkg:bitnami/kyvernoOther threatsAffected
  • <1.15.3
  • >=1.16.0 <1.16.3
Fixed in
  • 1.15.3
  • 1.16.3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Kyverno to version 1.15.3 or later, or 1.16.3 or later, where the vulnerability is patched. No other mitigation is indicated or required according to the available data.

Description

Kyverno versions prior to 1.15.3 and versions from 1.16.0 up to but not including 1.16.3 contain a vulnerability in the policy engine that allows users with policy creation privileges to cause denial of service by crafting policies that exponentially amplify string data via context variables, leading to unbounded memory consumption. This issue is patched in versions 1.15.3 and 1.16.3.

References

Community reviews

Loading reviews…