Kyverno versions prior to 1.15.3 and versions from 1.16.0 up to but not including 1.16.3 contain a vulnerability in the policy engine that allows users with policy creation privileges to cause denial of service by crafting policies that exponentially amplify string data via context variables, leading to unbounded memory consumption. This issue is patched in versions 1.15.3 and 1.16.3.