Skip to main content
CVE-2026-122322VulnerabilityPublished

Kyverno from 1.11.0 before 1.19.2 contains an unbounded decompression vulnerability in extractStatement that allows

Affects kyvernoSource GCVE Database

0
Compare
Authoritative record:CVE-2026-122322· High 8.7

Not known to be exploited · CVSS 8.7 High · fixed in 1.19.2 : patch kyverno soon.

Data as of 5 Nov 2026, 04:14 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.08.7
CNA (VulnCheck)CVSS 3.17.5
Patch
Available – fixed in 1.19.2
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 5 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Affected software

ProductAffectedFixed in
GitHubkyverno/kyvernopkg:github/kyverno/kyvernoOther threatsAffected–Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fixed version is available starting from Kyverno 1.19.2. Users should upgrade to version 1.19.2 or later to remediate this vulnerability. Since this is not a cloud service, remediation requires applying the official patch by upgrading the software. No other mitigations or workarounds are specified.

Description

Kyverno versions from 1.11.0 up to but not including 1.19.2 contain an unbounded decompression vulnerability in the extractStatement function. This flaw allows remote attackers to cause denial of service by exhausting memory resources through highly compressed attestation layers. Specifically, attackers controlling registry referrer artifacts can push gzip predicate layers that exceed the maximum payload size when decompressed, leading to out-of-memory (OOM) kills of the admission controller.

References

Community reviews

Loading reviews…