CVE-2026-25879: Langroid has Prompt to SQL Injection, Leading to RCE
Affects langroidSource GCVE Database
Not known to be exploited · CVSS 9.8 Critical : upgrade to 0.63.0 as a priority.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 46% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.63.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 27 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade langroid to 0.63.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| PyPIlangroid | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in Langroid version 0.63.0, which defaults SQLChatAgent to a SELECT-only SQL statement allowlist with a dialect-aware blocklist for dangerous patterns. Users should upgrade to version 0.63.0 or later. For deployments requiring unrestricted SQL operations, the allow_dangerous_operations flag must be explicitly enabled only in trusted environments. Until upgraded, users should restrict database roles to minimize privileges that allow execution of system commands and avoid exposing the SQLChatAgent to untrusted input.
Description
Langroid versions prior to 0.63.0 contain a vulnerability in the SQLChatAgent component where SQL queries generated by a large language model (LLM) are executed without sufficient validation. This allows an attacker who can influence the LLM's input to inject SQL commands that leverage database-specific features (e.g., PostgreSQL's COPY FROM PROGRAM) to execute arbitrary system commands, resulting in remote code execution (RCE) on the database host. The vulnerability arises when the database role has elevated privileges that permit such operations. The issue is fixed in version 0.63.0 by restricting SQLChatAgent to a safe subset of SQL commands and blocking dangerous patterns by default. The vulnerability is critical due to its potential for full system compromise via the database server.
References
- github.com/langroid/langroid/security/advisories/GHSA-mxfr-6hcw-j9rq (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-25879 (opens in a new tab)
- github.com/langroid/langroid (opens in a new tab)
- github.com/pypa/advisory-database/tree/main/vulns/langroid/PYSEC-2026-382.yaml (opens in a new tab)
- pypi.org/project/langroid (opens in a new tab)