Skip to main content
VulnerabilityPublished

CVE-2026-92772: Leantime before 3.9.6 contains an authorization bypass vulnerability in the HTMX plugin install endpoint that lacks permission validation

Affects leantimeSource GCVE Database

0
Compare

Not known to be exploited · CVSS 7.1 High : upgrade to 3.9.6 soon.

Data as of 31 Oct 2026, 20:20 UTC

CVSS 3.1 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 44% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.9.6
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 16 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.

What to do

Upgrade leantime/leantime to 3.9.6.

Affected software

ProductAffectedFixed in
GitHubleantime/leantimepkg:github/leantime/leantimeOther threatsAffected
  • <3.9.6
Fixed in
  • 3.9.6

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in Leantime version 3.9.6. Users should upgrade to version 3.9.6 or later to remediate this vulnerability. Since no vendor advisory or patch links are provided, confirm patch availability from official Leantime sources before applying updates. Until patched, restrict plugin installation permissions strictly to trusted administrators.

Description

Leantime versions before 3.9.6 have an authorization bypass vulnerability in the HTMX plugin install endpoint. This flaw allows authenticated users with limited roles to install marketplace plugins without proper permission validation. Attackers can manipulate plugin properties such as identifier, version, and license key to deploy malicious plugins.

References

Community reviews

Loading reviews…