Legit: GitPython reference APIs has a path traversal vulnerability that allows arbitrary file write and delete outside
Affects legitSource GCVE Database
Public exploit available · CVSS 7.8 High : upgrade to 1.2.0.post0_9 as a priority.
Data as of 26 Oct 2026, 19:13 UTC
- Patch
- Available – fixed in 1.2.0.post0_9
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:H/SC:N/SI:N/SA:N/E:PExploitation evidence
Disclosed: evidence found.
CVE published 7 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: evidence found.
CVSS exploit maturity: proof of concept public
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade legit to 1.2.0.post0_9.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewlegitpkg:brew/legitOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in GitPython version 1.2.0.post0_9 and later. The recommended mitigation is to upgrade to this fixed version. The fix involves validating reference paths before write, rename, and delete operations to ensure they do not escape the repository boundaries. Applications should avoid passing user-controlled input directly to GitPython reference APIs without validation. Since a patch is available, applying the official fix is the primary remediation.
Description
GitPython versions up to 3.1.46 and the current main branch (3.1.47 locally) contain a path traversal vulnerability in their reference APIs. This flaw allows attackers who can supply crafted reference paths to write, overwrite, move, or delete files outside the repository's .git directory due to insufficient validation of reference paths during write, rename, and delete operations. The vulnerability requires local access to influence reference names passed to GitPython APIs. It can lead to high integrity and availability impacts by corrupting or deleting arbitrary files accessible by the process.
References
- github.com/gitpython-developers/GitPython/security/advisories/GHSA-7545-fcxq-7j24 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-44243 (opens in a new tab)
- github.com/gitpython-developers/GitPython (opens in a new tab)
- github.com/gitpython-developers/GitPython/releases/tag/3.1.48 (opens in a new tab)