Skip to main content
VulnerabilityPublished Updated

CVE-2026-78127: strongSwan · Libcharon

Affects strongswanSource GCVE Database

0
Compare

Not known to be exploited · CVSS 3.7 Low · fixed in 5.9.5-2ubuntu2.8 : update strongswan when convenient.

Data as of 5 Nov 2026, 23:24 UTC

CVSS 3.1 base score
3.7Low
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 35% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.9.5-2ubuntu2.8, 5.9.13-2ubuntu4.24.04.5, 6.0.4-1ubuntu3.2
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade the Ubuntu strongswan to 5.9.5-2ubuntu2.8 (package) or 5.9.13-2ubuntu4.24.04.5 (package) or 6.0.4-1ubuntu3.2 (package).

Affected software

ProductAffectedFixed in
Ubuntu 26.04 LTSstrongswanpkg:deb/ubuntu/strongswan?arch=source&distro=resoluteOther threatsAffected
  • <6.0.4-1ubuntu3.2
Fixed in
  • 6.0.4-1ubuntu3.2
Ubuntu 24.04 LTSstrongswanpkg:deb/ubuntu/strongswan?arch=source&distro=nobleOther threatsAffected
  • <5.9.13-2ubuntu4.24.04.5
Fixed in
  • 5.9.13-2ubuntu4.24.04.5
Ubuntu 22.04 LTSstrongswanpkg:deb/ubuntu/strongswan?arch=source&distro=jammyOther threatsAffected
  • <5.9.5-2ubuntu2.8
Fixed in
  • 5.9.5-2ubuntu2.8
Ubuntu Pro FIPS-preview 22.04 LTSstrongswanpkg:deb/ubuntu/strongswan?arch=source&distro=fips-preview/jammyOther threatsAffected
  • =5.9.5-2ubuntu2.1+Fips1
  • =5.9.5-2ubuntu2.2+Fips1
Fixed in–
Ubuntu Pro FIPS-updates 22.04 LTSstrongswanpkg:deb/ubuntu/strongswan?arch=source&distro=fips-updates/jammyOther threatsAffected
  • 5.9.5-2ubuntu2.1+Fips1 – 5.9.5-2ubuntu2.8+Fips1
8 affected builds
Fixed in–
Ubuntu 20.04 LTSstrongswanpkg:deb/ubuntu/strongswan?arch=source&distro=focalOther threatsAffected
  • 5.7.2-1ubuntu3 – 5.8.2-1ubuntu3.6
11 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available and has been released by Ubuntu in security updates. Users should update strongSwan packages to the fixed versions listed in the Ubuntu advisory USN-8789-1. Applying these official patches will remediate the vulnerability. No additional mitigation steps are required beyond applying the vendor-provided updates.

Description

A memory release issue exists in the libcharon component of strongSwan versions 4.1.2 through 6.0.7 in the IKE message parser. This flaw can lead to a denial of service or potential information disclosure due to improper memory handling. The vulnerability has a medium severity rating with a CVSS score of 3.7. Official patches addressing this issue are available in updated strongSwan packages for various Ubuntu LTS releases.

References

Community reviews

Loading reviews…