CVE-2026-78124: strongSwan 5.0.2 through 6.0.7 allows PKCS#7 certificate enumeration in the openssl plugin that leads to a lack of release of memory after its
Affects strongswanSource GCVE Database
Not known to be exploited · CVSS 3.7 Low · fixed in 5.9.5-2ubuntu2.8 : update strongswan when convenient.
Data as of 5 Nov 2026, 00:01 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 17% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 5.9.5-2ubuntu2.8, 5.9.13-2ubuntu4.24.04.5, 6.0.4-1ubuntu3.2
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 7 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.
What to do
Upgrade the Ubuntu strongswan to 5.9.5-2ubuntu2.8 (package) or 5.9.13-2ubuntu4.24.04.5 (package) or 6.0.4-1ubuntu3.2 (package).
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.04 LTSstrongswanpkg:deb/ubuntu/strongswan?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSstrongswanpkg:deb/ubuntu/strongswan?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 22.04 LTSstrongswanpkg:deb/ubuntu/strongswan?arch=source&distro=jammyOther threats | Affected
| Fixed in
|
Ubuntu Pro FIPS-preview 22.04 LTSstrongswanpkg:deb/ubuntu/strongswan?arch=source&distro=fips-preview/jammyOther threats | Affected
| Fixed in– |
Ubuntu Pro FIPS-updates 22.04 LTSstrongswanpkg:deb/ubuntu/strongswan?arch=source&distro=fips-updates/jammyOther threats | Affected
| Fixed in– |
Ubuntu 20.04 LTSstrongswanpkg:deb/ubuntu/strongswan?arch=source&distro=focalOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix for this vulnerability is available. Users should update strongSwan to the patched versions provided by their Linux distribution vendors. For Ubuntu, the patched package versions are: 6.0.4-1ubuntu3.2 for Ubuntu 26.04 LTS, 5.9.13-2ubuntu4.24.04.5 for Ubuntu 24.04 LTS, and 5.9.5-2ubuntu2.8 for Ubuntu 22.04 LTS. Applying these updates will remediate the vulnerability. Standard system updates will include these fixes.
Description
strongSwan versions 5.0.2 through 6.0.7 contain a vulnerability in the openssl plugin related to incorrect memory handling when enumerating certificates in PKCS#7 containers. This flaw can lead to a lack of memory release after the certificate's effective lifetime, potentially allowing a remote attacker to obtain sensitive information. The issue has a medium severity rating with a CVSS score of 3.7. Official patches addressing this vulnerability are available for multiple Ubuntu releases.