CVE-2026-111269: libical security update
Affects libicalSource GCVE Database
Not known to be exploited · CVSS 6.9 Medium : upgrade to 3.0.17-4.oe2403sp4 when convenient.
Data as of 29 Oct 2026, 11:05 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 6.9 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 6.1 |
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 2% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.0.17-4.oe2403sp4
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:L/VI:N/VA:H/SC:N/SI:N/SA:NExploitation evidence
t = 0 is the CVE’s publication on cve.org
Disclosed: evidence found.
CVE published 15 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: evidence found.
CISA SSVC: proof of concept public
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
Timeline
CVE ID reserved
by VulnCheck
, 2 hours before disclosure
CVE published
on cve.org
, t = 0
CISA SSVC assessment
proof of concept public
, 11 days after disclosure
In Threat Radar
record ingested
, 11 days after disclosure
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CISA SSVC, the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade libical to 3.0.17-4.oe2403sp4.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
openEuler 24.03-LTS-SP4libicalpkg:rpm/openEuler/libical&distro=openEuler-24.03-LTS-SP4Other threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A security fix is available in libical version 3.0.17-4.oe2403sp4. Users and administrators should upgrade to this fixed version to remediate the vulnerability. No other mitigation or workaround is indicated by the vendor advisory.
Description
A heap-based out-of-bounds read vulnerability exists in libical through version 4.0.6 in the function icalvalue_decode_ical_string() when decoding input that ends with a backslash. This flaw can cause the application to crash or leak adjacent heap memory when processing specially crafted escaped iCalendar text with a trailing backslash. The issue is fixed in version 3.0.17-4.oe2403sp4.