Skip to main content
VulnerabilityPublished

CVE-2026-110602: libmspack vulnerability

Affects libmspackSource GCVE Database

0
Compare
Authoritative record:CVE-2026-110602· Medium 5.8

Not known to be exploited · CVSS 5.8 Medium · fixed in 0.10.1-2ubuntu0.1 : update libmspack when convenient.

Data as of 4 Nov 2026, 04:01 UTC

CVSS 4.0 base score
5.8Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 0.10.1-2ubuntu0.1, 0.11-1.1ubuntu0.24.04.1, 0.11-1.1ubuntu0.26.10.1 +1
CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:P/VC:N/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 26.10libmspackpkg:deb/ubuntu/libmspack?arch=source&distro=stonkingOther threatsAffected
  • <0.11-1.1ubuntu0.26.10.1
Fixed in
  • 0.11-1.1ubuntu0.26.10.1
Ubuntu 26.04 LTSlibmspackpkg:deb/ubuntu/libmspack?arch=source&distro=resoluteOther threatsAffected
  • <0.11-1.1ubuntu0.26.04.1
Fixed in
  • 0.11-1.1ubuntu0.26.04.1
Ubuntu 24.04 LTSlibmspackpkg:deb/ubuntu/libmspack?arch=source&distro=nobleOther threatsAffected
  • <0.11-1.1ubuntu0.24.04.1
Fixed in
  • 0.11-1.1ubuntu0.24.04.1
Ubuntu 22.04 LTSlibmspackpkg:deb/ubuntu/libmspack?arch=source&distro=jammyOther threatsAffected
  • <0.10.1-2ubuntu0.1
Fixed in
  • 0.10.1-2ubuntu0.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available and users should update libmspack to the patched versions provided by Ubuntu for their respective releases. A standard system update will apply the necessary changes. The fixed package versions are 0.10.1-2ubuntu0.1 for Ubuntu 22.04 LTS, 0.11-1.1ubuntu0.24.04.1 for Ubuntu 24.04 LTS, 0.11-1.1ubuntu0.26.04.1 for Ubuntu 26.04 LTS, and 0.11-1.1ubuntu0.26.10.1 for Ubuntu 26.10. No additional mitigation steps are indicated by the vendor.

Description

A vulnerability in libmspack was found where pointers were not properly initialized when handling errors in KWAJ archive headers. This flaw could allow an attacker to cause a denial of service by crashing libmspack or potentially execute arbitrary code. Fixed versions are available for multiple Ubuntu releases.

References

Community reviews

Loading reviews…