Libnet idn encode perl: Net::IDN::Punycode versions from 2.301 before 2.590 for Perl allow a heap use-after-free via a
Affects libnet-idn-encode-perlSource GCVE Database
Mentioned vulnerabilities
Not known to be exploited · CVSS 8.4 High · fixed in 2.590 : patch libnet-idn-encode-perl soon.
Data as of 5 Nov 2026, 00:01 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 3% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.590
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 22 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.10libnet-idn-encode-perlpkg:deb/ubuntu/libnet-idn-encode-perl?arch=source&distro=stonkingOther threats | Affected
| Fixed in– |
Ubuntu 26.04 LTSlibnet-idn-encode-perlpkg:deb/ubuntu/libnet-idn-encode-perl?arch=source&distro=resoluteOther threats | Affected
| Fixed in– |
Ubuntu 24.04 LTSlibnet-idn-encode-perlpkg:deb/ubuntu/libnet-idn-encode-perl?arch=source&distro=nobleOther threats | Affected
| Fixed in– |
Ubuntu 22.04 LTSlibnet-idn-encode-perlpkg:deb/ubuntu/libnet-idn-encode-perl?arch=source&distro=jammyOther threats | Affected
| Fixed in– |
Ubuntu 20.04 LTSlibnet-idn-encode-perlpkg:deb/ubuntu/libnet-idn-encode-perl?arch=source&distro=focalOther threats | Affected
| Fixed in– |
Ubuntu 18.04 LTSlibnet-idn-encode-perlpkg:deb/ubuntu/libnet-idn-encode-perl?arch=source&distro=bionicOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fixed version is available starting from 2.590. Users should upgrade to version 2.590 or later to remediate this vulnerability. No other mitigation or workaround is indicated.
Description
Net::IDN::Punycode versions from 2.301 before 2.590 for Perl contain a heap use-after-free vulnerability in the XS backend's decode_punycode function. This flaw occurs when decoding punycode labels with code points above U+FFFF, which causes the output buffer to reallocate improperly, leading to use of freed memory. The vulnerability allows reading and writing of freed heap memory, potentially resulting in high impact on confidentiality, integrity, and availability.
References
- ubuntu.com/security/CVE-2026-74766 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-74766 (opens in a new tab)
- lists.security.metacpan.org/cve-announce/msg/43753027/ (opens in a new tab)
- github.com/robrwo/Net-IDN-Encode/commit/259e74c5739175b063c5393a4ce4a0705678ba61.patch (opens in a new tab)
- github.com/robrwo/Net-IDN-Encode/commit/2fbc71e4d8517ab65c5d5d35fda086371b735a3f.patch (opens in a new tab)
- metacpan.org/release/PJCJ/Net-IDN-Encode-2.590-TRIAL/changes (opens in a new tab)
- cve.org/CVERecord?id=CVE-2016-15059 (opens in a new tab)