Skip to main content
VulnerabilityPublished Updated

CVE-2026-87078: Libnet idn encode perl · Net::IDN::Punycode versions from 2.302 before 2.590 for Perl leak the output

Affects libnet-idn-encode-perlSource GCVE Database

0
Compare
Authoritative record:CVE-2026-87078· Critical 9.1

Not known to be exploited · CVSS 9.1 Critical · fixed in 2.590 : patch libnet-idn-encode-perl as a priority.

Data as of 5 Nov 2026, 00:01 UTC

CVSS 3.1 base score
9.1Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 33% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.590
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Affected software

ProductAffectedFixed in
Ubuntu 26.10libnet-idn-encode-perlpkg:deb/ubuntu/libnet-idn-encode-perl?arch=source&distro=stonkingOther threatsAffected
  • =2.500-5build1
  • =2.500-5build2
Fixed in–
Ubuntu 26.04 LTSlibnet-idn-encode-perlpkg:deb/ubuntu/libnet-idn-encode-perl?arch=source&distro=resoluteOther threatsAffected
  • =2.500-5build1
Fixed in–
Ubuntu 24.04 LTSlibnet-idn-encode-perlpkg:deb/ubuntu/libnet-idn-encode-perl?arch=source&distro=nobleOther threatsAffected
  • 2.500-3 – 2.500-5
4 affected builds
Fixed in–
Ubuntu 22.04 LTSlibnet-idn-encode-perlpkg:deb/ubuntu/libnet-idn-encode-perl?arch=source&distro=jammyOther threatsAffected
  • =2.500-1build2
  • =2.500-2
  • =2.500-2build1
Fixed in–
Ubuntu 20.04 LTSlibnet-idn-encode-perlpkg:deb/ubuntu/libnet-idn-encode-perl?arch=source&distro=focalOther threatsAffected
  • =2.500-1
  • =2.500-1build1
Fixed in–
Ubuntu 18.04 LTSlibnet-idn-encode-perlpkg:deb/ubuntu/libnet-idn-encode-perl?arch=source&distro=bionicOther threatsAffected
  • =2.400-1build1
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fixed version of Net::IDN::Punycode is available starting from version 2.590. Users should upgrade to version 2.590 or later to remediate this vulnerability. No other mitigation is indicated.

Description

Net::IDN::Punycode versions from 2.302 before 2.590 for Perl contain a vulnerability in the XS backend where the output buffer is leaked on every rejected label in decode_punycode. This occurs because the scalar buffer is allocated before input validation and only released on successful decoding, causing memory to be retained on failure. The flaw allows an attacker supplying invalid labels to grow the process memory by twice the label length per rejected call without needing a successful call.

References

Community reviews

Loading reviews…