CVE-2026-108985: libnfs security update
Affects libnfsSource GCVE Database
Not known to be exploited · CVSS 7.1 High : upgrade to 5.0.2-4.oe2403sp3 soon.
Data as of 4 Nov 2026, 16:46 UTC
- Patch
- Available – fixed in 5.0.2-4.oe2403sp3
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:HExploitation evidence
Disclosed: evidence found.
CVE published 12 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.
What to do
Upgrade libnfs to 5.0.2-4.oe2403sp3.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
openEuler 24.03-LTS-SP3libnfspkg:rpm/openEuler/libnfs&distro=openEuler-24.03-LTS-SP3Other threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available in libnfs version 5.0.2-4.oe2403sp3. Users and administrators should upgrade to this fixed version to remediate the vulnerability. No additional mitigation steps are indicated by the vendor advisory.
Description
A security vulnerability in libnfs versions prior to 5.0.2-4.oe2403sp3 involves an out-of-bounds write in the ZDR decoding functionality. The flaw occurs because the maxsize parameter supplied by the caller is not properly enforced, affecting functions libnfs_zdr_bytes(), libnfs_zdr_string(), and libnfs_zdr_array(). This vulnerability has been assigned CVE-2026-108985 and is rated with a high severity score of 7.1.