CVE-2026-74220: uboot-tools security update
Affects uboot-toolsSource GCVE Database
Mentioned vulnerabilities
Not known to be exploited · CVSS 8.2 High : upgrade to 2024.01-6.oe2403sp3 soon.
Data as of 4 Nov 2026, 16:46 UTC
- Patch
- Available – fixed in 2024.01-6.oe2403sp3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:HExploitation evidence
Disclosed: evidence found.
CVE published 4 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.
What to do
Upgrade uboot-tools to 2024.01-6.oe2403sp3.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
openEuler 24.03-LTS-SP3uboot-toolspkg:rpm/openEuler/uboot-tools&distro=openEuler-24.03-LTS-SP3Other threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and fixed these vulnerabilities in uboot-tools version 2024.01-6.oe2403sp3. Users should upgrade to this version or later to mitigate the risk. No additional vendor advisories indicate alternative mitigations or that no action is required.
Description
U-Boot versions prior to 2024.01-6.oe2403sp3 contain buffer overflow vulnerabilities in the nfs_read_reply() and nfs_readlink_reply() functions. These flaws allow a malicious NFS server to send crafted responses that exploit signed integer handling and length validation bypasses, leading to memory corruption and potential bootloader crashes.