CVE-2026-116695: rubygem-crass security update
Affects rubygem-crassSource GCVE Database
Mentioned vulnerabilities
Not known to be exploited · CVSS 5.3 Medium : upgrade to 1.0.8-1.oe2403sp3 when convenient.
Data as of 4 Nov 2026, 16:47 UTC
Thin evidence
One scorer or none| CNA (GitHub_M) | CVSS 4.0 | 5.3 |
|---|
- Patch
- Available – fixed in 1.0.8-1.oe2403sp3
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 27 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.
What to do
Upgrade rubygem-crass to 1.0.8-1.oe2403sp3.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
openEuler 24.03-LTS-SP3rubygem-crasspkg:rpm/openEuler/rubygem-crass&distro=openEuler-24.03-LTS-SP3Other threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade rubygem-crass to version 1.0.8 or later, which includes fixes for all described vulnerabilities. The vendor has released official fixes in versions 1.0.7 and 1.0.8 addressing these issues. No additional mitigation is required once the update is applied.
Description
Crass is a Ruby CSS parser compliant with the CSS Syntax Level 3 specification. Multiple vulnerabilities affect versions prior to 1.0.8, including improper handling of escaped characters in URLs that may allow CSS-based UI redress or data exfiltration, recursive parsing without depth limits causing stack overflow or excessive memory use, excessive recursion triggered by many adjacent comments leading to denial of service, and inefficient parsing of non-ASCII characters causing high CPU usage and potential denial of service. These issues are fixed in versions 1.0.7 and 1.0.8.
References
- openeuler.org/zh/security/security-bulletins/detail/?id=openEuler-SA-2026-4724 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-116695 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-61846 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-61847 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-61848 (opens in a new tab)