Skip to main content
CVE-2025-54119VulnerabilityPublished Updated

Libphp adodb:

Affects libphp-adodbSource GCVE Database

0
Compare
Authoritative record:CVE-2025-54119· Critical 10.0

Not known to be exploited · CVSS 10.0 Critical · fixed in 5.22.10 : patch libphp-adodb as a priority.

Data as of 5 Nov 2026, 00:01 UTC

CVSS 3.1 base score
10.0Critical
How severe the flaw is on the 0–10 CVSS scale.

Contested

Critical score, yet low EPSS after six months · One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 3.110.0
EPSS
0.5% chance of exploitation in 30 days – higher than 45% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.22.10
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 5 Aug 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Affected software

ProductAffectedFixed in
Ubuntu 26.10libphp-adodbpkg:deb/ubuntu/libphp-adodb?arch=source&distro=stonkingOther threatsAffected
  • =5.22.11-1
Fixed in–
Ubuntu 25.10libphp-adodbpkg:deb/ubuntu/libphp-adodb?arch=source&distro=questingOther threatsAffected
  • =5.22.8-0.1
  • =5.22.9-0.1
Fixed in–
Ubuntu Pro 24.04 LTSlibphp-adodbpkg:deb/ubuntu/libphp-adodb?arch=source&distro=esm-apps/nobleOther threatsAffected
  • =5.21.4-1
  • =5.21.4-1ubuntu0.1~esm1
Fixed in–
Ubuntu Pro 22.04 LTSlibphp-adodbpkg:deb/ubuntu/libphp-adodb?arch=source&distro=esm-apps/jammyOther threatsAffected
  • =5.20.19-1
  • =5.20.19-1ubuntu0.1
  • =5.20.19-1ubuntu0.1+esm1
Fixed in–
Ubuntu Pro 20.04 LTSlibphp-adodbpkg:deb/ubuntu/libphp-adodb?arch=source&distro=esm-apps/focalOther threatsAffected
  • 5.20.14-1 – 5.20.16-1ubuntu0.1~esm2
5 affected builds
Fixed in–
Ubuntu Pro 18.04 LTSlibphp-adodbpkg:deb/ubuntu/libphp-adodb?arch=source&distro=esm-apps/bionicOther threatsAffected
  • =5.20.9-1
  • =5.20.9-1ubuntu0.1~esm1
  • =5.20.9-1ubuntu0.1~esm2
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade libphp-adodb to version 5.22.10 or later where the vulnerability is fixed. As a temporary workaround, ensure that only controlled and trusted data is passed to the metaColumns(), metaForeignKeys(), and metaIndexes() methods' $table parameter to prevent exploitation.

Description

Libphp-adodb versions 5.22.9 and below contain a critical vulnerability due to improper escaping of query parameters when interacting with sqlite3 databases. This flaw allows attackers to execute arbitrary SQL statements by passing crafted table names to the metaColumns(), metaForeignKeys(), or metaIndexes() methods. The issue is resolved in version 5.22.10. Users are advised to upgrade or ensure only controlled data is passed to these methods.

References

Community reviews

Loading reviews…