Libphp adodb: Prior to version 5.22.9, improper escaping of a query parameter may allow an attacker to execute
Affects libphp-adodbSource GCVE Database
Not known to be exploited · CVSS 10.0 Critical · fixed in 5.20.3-1ubuntu1+esm2 : patch libphp-adodb as a priority.
Data as of 5 Nov 2026, 00:01 UTC
- EPSS
- 0.7% chance of exploitation in 30 days – higher than 55% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 5.20.3-1ubuntu1+esm2, 5.20.9-1ubuntu0.1~esm2, 5.20.16-1ubuntu0.1~esm2 +3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:LExploitation evidence
Disclosed: evidence found.
CVE published 1 May 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.04 LTSlibphp-adodbpkg:deb/ubuntu/libphp-adodb?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 25.10libphp-adodbpkg:deb/ubuntu/libphp-adodb?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Ubuntu Pro 24.04 LTSlibphp-adodbpkg:deb/ubuntu/libphp-adodb?arch=source&distro=esm-apps/nobleOther threats | Affected
| Fixed in
|
Ubuntu Pro 22.04 LTSlibphp-adodbpkg:deb/ubuntu/libphp-adodb?arch=source&distro=esm-apps/jammyOther threats | Affected
| Fixed in
|
Ubuntu Pro 20.04 LTSlibphp-adodbpkg:deb/ubuntu/libphp-adodb?arch=source&distro=esm-apps/focalOther threats | Affected
| Fixed in
|
Ubuntu Pro 18.04 LTSlibphp-adodbpkg:deb/ubuntu/libphp-adodb?arch=source&distro=esm-apps/bionicOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Apply the official patches provided by Ubuntu by updating libphp-adodb to version 5.22.9 or later. The updates are available for multiple Ubuntu releases including 16.04 LTS, 18.04 LTS, 20.04 LTS, 22.04 LTS, and 24.04 LTS. Standard system updates will apply the necessary fixes. No additional mitigation is required once patched.
Description
ADOdb, a PHP database abstraction library, contains a critical vulnerability prior to version 5.22.9 where improper escaping of query parameters can allow remote attackers to execute arbitrary SQL commands when connecting to PostgreSQL databases and using pg_insert_id() with user input. This flaw has been patched in version 5.22.9. The vulnerability has a CVSS score of 10.0, indicating critical severity with network attack vector, no privileges required, no user interaction, and impacts confidentiality, integrity, and availability. Ubuntu has released security updates for multiple supported releases to address this issue.
References
- ubuntu.com/security/CVE-2025-46337 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2025-46337 (opens in a new tab)
- github.com/ADOdb/ADOdb/security/advisories/GHSA-8x27-jwjr-8545 (opens in a new tab)
- github.com/ADOdb/ADOdb/issues/1070 (opens in a new tab)
- github.com/ADOdb/ADOdb/commit/11107d6d6e5160b62e05dff8a3a2678cf0e3a426 (opens in a new tab)
- ubuntu.com/security/notices/USN-7530-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7530-2 (opens in a new tab)