Skip to main content
CVE-2026-1761VulnerabilityPublished Updated

SUSE · Security update for libsoup2

Affects SUSESource GCVE Database

0
Authoritative record:CVE-2026-1761· High 8.6

Not known to be exploited · CVSS 8.6 High : upgrade the Red Hat redhat/libsoup package to 9.2.10 or 8.8.8 soon.

Data as of 26 Oct 2026, 11:07 UTC

CVSS 3.1 base score
8.6High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
1.0% chance of exploitation in 30 days – higher than 64% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 9.2.10, 8.8.8
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:H/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 2 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade the Red Hat redhat/libsoup package to 9.2.10 or 8.8.8.

Affected software

ProductAffectedFixed in
Red Hatredhat/libsouppkg:rpm/redhat/libsoupOther threatsAffected
  • >=8.8 <8.8.8
  • >=9.2 <9.2.10
Fixed in
  • 8.8.8
  • 9.2.10

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

An official patch is available from Red Hat and SUSE. Users should apply the security update for libsoup2 as provided in the vendor advisories to remediate this vulnerability. No additional mitigation steps are required beyond applying the official fix.

Description

A security update for libsoup2 addresses a stack-based buffer overflow vulnerability (CVE-2026-1761) caused by incorrect length calculation when parsing multipart HTTP responses. This vulnerability is rated as high severity. The issue affects multiple versions of libsoup2 in SUSE and Red Hat Enterprise Linux distributions. A patch is available and should be applied to mitigate the risk.

References

Community reviews

Loading reviews…