Skip to main content
CVE-2024-47538VulnerabilityPublished Updated

SUSE · security update for gstreamer1-plugins-base

Affects SUSESource GCVE Database

0

Mentioned vulnerabilities

Not known to be exploited : upgrade the Red Hat redhat/gstreamer1-plugins-base package to 9.8 or 9.6 soon.

Data as of 26 Oct 2026, 08:30 UTC

Severity
High

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
1.2% chance of exploitation in 30 days – higher than 69% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 9.8, 9.6

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 16 Dec 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade the Red Hat redhat/gstreamer1-plugins-base package to 9.8 or 9.6.

Affected software

ProductAffectedFixed in
Red Hatredhat/gstreamer1-plugins-basepkg:rpm/redhat/gstreamer1-plugins-baseOther threatsAffected
  • <9.6
  • <9.8
  • >=9.8
Fixed in
  • 9.6
  • 9.8

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has issued security updates for the gstreamer1-plugins-base package that address these vulnerabilities. Users should apply the provided updates as soon as possible to remediate the issues. For detailed instructions on applying the updates, refer to the Red Hat advisory at https://access.redhat.com/articles/11258. Since patches are available, applying the official fixes is the recommended mitigation.

Description

Multiple security vulnerabilities have been identified in the gstreamer1-plugins-base package used in Red Hat Enterprise Linux 9. These include stack-buffer overflows in vorbis_handle_identification_packet and gst_opus_dec_parse_header, as well as an out-of-bounds write in the Ogg demuxer. Red Hat has issued an important security advisory with updates to address these issues. The vulnerabilities affect various architectures and extended update support versions of Red Hat Enterprise Linux 9. The security impact is rated as high. A patch is available to remediate these issues.

References

Community reviews

Loading reviews…