Skip to main content
VulnerabilityPublished Updated

CVE-2025-4877: libssh vulnerabilities

Affects libsshSource GCVE Database

0

Mentioned vulnerabilities

Authoritative record:CVE-2025-4877· Medium 4.5

Not known to be exploited · CVSS 4.5 Medium · fixed in 0.6.3-4.3ubuntu0.6+esm2 : update libssh when convenient.

Data as of 27 Oct 2026, 06:42 UTC

CVSS 3.1 base score
4.5Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 0.6.3-4.3ubuntu0.6+esm2, 0.8.0~20170825.94fa1e38-1ubuntu0.7+esm4, 0.9.3-2ubuntu2.5+esm1
CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 20 Aug 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade the Ubuntu libssh to 0.6.3-4.3ubuntu0.6+esm2 (package) or 0.8.0~20170825.94fa1e38-1ubuntu0.7+esm4 (package) or 0.9.3-2ubuntu2.5+esm1 (package).

Affected software

ProductAffectedFixed in
Ubuntu Pro 20.04 LTSlibsshpkg:deb/ubuntu/libssh?arch=source&distro=esm-infra/focalOther threatsAffected
  • <0.9.3-2ubuntu2.5+esm1
Fixed in
  • 0.9.3-2ubuntu2.5+esm1
Ubuntu Pro 18.04 LTSlibsshpkg:deb/ubuntu/libssh?arch=source&distro=esm-infra/bionicOther threatsAffected
  • <0.8.0~20170825.94fa1e38-1ubuntu0.7+esm4
Fixed in
  • 0.8.0~20170825.94fa1e38-1ubuntu0.7+esm4
Ubuntu Pro 16.04 LTSlibsshpkg:deb/ubuntu/libssh?arch=source&distro=esm-infra/xenialOther threatsAffected
  • <0.6.3-4.3ubuntu0.6+esm2
Fixed in
  • 0.6.3-4.3ubuntu0.6+esm2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

Ronald Crane discovered that libssh incorrectly handled certain base64 conversions. An attacker could use this issue to cause libssh to crash, resulting in a denial of service, or possibly execute arbitrary code. (CVE-2025-4877) Ronald Crane discovered that libssh incorrectly handled the privatekey_from_file() function. An attacker could use this issue to cause libssh to crash, resulting in a denial of service, or possibly execute arbitrary code. (CVE-2025-4878) Ronald Crane discovered that libssh incorrectly handled certain memory operations in the sftp server. An attacker could possibly use this issue to cause libssh to crash, resulting in a denial of service. (CVE-2025-5318)

References

Community reviews

Loading reviews…