Skip to main content
VulnerabilityPublished

CVE-2026-109089: libXi security update

Affects libXiSource GCVE Database

0
Compare
Authoritative record:CVE-2026-109089· High 7.5

Not known to be exploited · CVSS 7.5 High : upgrade to 1.8.1-6.oe2403sp3 soon.

Data as of 29 Oct 2026, 10:49 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (suse)CVSS 3.17.5
EPSS
0.2% chance of exploitation in 30 days – higher than 17% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.8.1-6.oe2403sp3
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade libXi to 1.8.1-6.oe2403sp3.

Affected software

ProductAffectedFixed in
openEuler 24.03-LTS-SP3libXipkg:rpm/openEuler/libXi&distro=openEuler-24.03-LTS-SP3Other threatsAffected
  • <1.8.1-6.oe2403sp3
Fixed in
  • 1.8.1-6.oe2403sp3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security update fixing these issues is available in libXi version 1.8.1-6.oe2403sp3. Users and administrators should upgrade to this fixed version to remediate the vulnerabilities. No additional mitigation steps are indicated by the vendor advisory.

Description

Multiple security issues were identified in the libXi client-side library for the X Input Extension, leading to a high-severity vulnerability tracked as CVE-2026-109089. These issues affect versions prior to 1.8.1-6.oe2403sp3 and have been addressed in the fixed release 1.8.1-6.oe2403sp3. The vulnerability has a CVSS 3.1 score of 7.5, indicating high impact on confidentiality, integrity, and availability.

References

Community reviews

Loading reviews…