CVE-2026-109089: libXi security update
Affects libXiSource GCVE Database
Not known to be exploited · CVSS 7.5 High : upgrade to 1.8.1-6.oe2403sp4 soon.
Data as of 29 Oct 2026, 10:49 UTC
Thin evidence
One scorer or none| CNA (suse) | CVSS 3.1 | 7.5 |
|---|
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 17% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.8.1-6.oe2403sp4
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 27 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade libXi to 1.8.1-6.oe2403sp4.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
openEuler 24.03-LTS-SP4libXipkg:rpm/openEuler/libXi&distro=openEuler-24.03-LTS-SP4Other threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A security update fixing these vulnerabilities is available in libXi version 1.8.1-6.oe2403sp4. Users and administrators should upgrade to this fixed version to remediate the issues.
Description
Multiple security issues were identified in libXi, the client-side library for the X Input Extension, leading to a high-severity vulnerability tracked as CVE-2026-109089. These issues affect versions prior to 1.8.1-6.oe2403sp4. A security update has been released to address these vulnerabilities.