CVE-2026-109089: libXi security update
Affects libXiSource GCVE Database
Not known to be exploited · CVSS 7.5 High : upgrade to 1.8.1-6.oe2403sp1 soon.
Data as of 29 Oct 2026, 10:49 UTC
Thin evidence
One scorer or none| CNA (suse) | CVSS 3.1 | 7.5 |
|---|
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 17% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.8.1-6.oe2403sp1
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 27 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade libXi to 1.8.1-6.oe2403sp1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
openEuler 24.03-LTS-SP1libXipkg:rpm/openEuler/libXi&distro=openEuler-24.03-LTS-SP1Other threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
An official patch is available in libXi version 1.8.1-6.oe2403sp1. Users and administrators should upgrade to this fixed version to remediate the vulnerability. No additional mitigation steps are indicated by the vendor advisory.
Description
CVE-2026-109089 is a high-severity vulnerability affecting libXi, the client-side library for the X Input Extension. Multiple security issues were identified in the X.Org client library implementations, prompting security fixes. The vulnerability impacts versions of libXi prior to 1.8.1-6.oe2403sp1. The CVSS 3.1 score is 7.5, indicating high impact on confidentiality, integrity, and availability. A patch is available in version 1.8.1-6.oe2403sp1.