Skip to main content
VulnerabilityPublished Updated

CVE-2025-24928: libxml2 before 2.12.10 and 2.13.x before 2.13.6 has a stack-based buffer overflow in

Source GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2025-24928· High 7.8

Not known to be exploited · CVSS 7.8 High : upgrade to 2.13.6 or 2.12.10 soon.

Data as of 30 Oct 2026, 16:04 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2.13.6, 2.12.10
CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 23 Jul 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade libxml2 and the Debian debian/libxml2 package to 2.13.6 or 2.12.10.

Affected software

ProductAffectedFixed in
xmlsoftlibxml2Affected
  • >=2.13.0 <2.13.6
Fixed in
  • 2.13.6
xmlsoftlibxml2Affected
  • <2.12.10
Fixed in
  • 2.12.10
Debiandebian/libxml2pkg:deb/debian/libxml2Other threatsAffected
  • <2.12.10
  • <2.13.6
Fixed in
  • 2.12.10
  • 2.13.6

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, avoid validating DTDs from untrusted sources to mitigate risk.

Description

A stack-based buffer overflow vulnerability exists in libxml2 versions before 2.12.10 and 2.13.x before 2.13.6 in the xmlSnprintfElements function within valid.c. Exploitation requires DTD validation of an untrusted document or DTD. This vulnerability is similar to CVE-2017-9047 and has a high severity rating with a CVSS score of 7.8.

References

Community reviews

Loading reviews…