Skip to main content
VulnerabilityPublished Updated

CVE-2026-31431: linux-aws-5.4, linux-hwe-5.4 vulnerabilities

Affects Linux kernelSource GCVE Database

0
Compare

Mentioned vulnerabilities

Exploited in the wild · KEV due 15 May 2026 · public exploit available (Metasploit) · 98% EPSS · fixed in 5.4.0-1160.170~18.04.1 : patch Linux kernel now.

Data as of 4 Nov 2026, 22:11 UTC

Exploitation

Actively exploited

High severity · No CVSS score from NVD or the CNA

KEV deadline
 US federal agencies must patch by this date; a sensible deadline for everyone else. Other KEV due dates
EPSS
98.1% chance of exploitation in 30 days – higher than 99% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.4.0-1160.170~18.04.1, 5.4.0-231.251~18.04.1

Exploitation evidence

t = 0 is the CVE’s publication on cve.org

  1. Disclosed: evidence found.

    CVE published 4 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    1 Metasploit module

  4. Exploited in the wild: evidence found.

    Listed in CISA KEV 34 days before disclosure

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

Timeline

  1. , 34 days before disclosure

  2. KEV remediation due

    US federal deadline

    , 20 days before disclosure

  3. CVE published

    on cve.org

    , t = 0

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CISA KEV (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade the Ubuntu to 5.4.0-1160.170~18.04.1 (linux-aws-5.4 package) or 5.4.0-231.251~18.04.1 (linux-hwe-5.4 package).

Affected software

ProductAffectedFixed in
Ubuntu Pro 18.04 LTSlinux-aws-5.4pkg:deb/ubuntu/linux-aws-5.4?arch=source&distro=esm-infra/bionicOther threatsAffected
  • <5.4.0-1160.170~18.04.1
Fixed in
  • 5.4.0-1160.170~18.04.1
Ubuntu Pro 18.04 LTSlinux-hwe-5.4pkg:deb/ubuntu/linux-hwe-5.4?arch=source&distro=esm-infra/bionicOther threatsAffected
  • <5.4.0-231.251~18.04.1
Fixed in
  • 5.4.0-231.251~18.04.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

Multiple security vulnerabilities were discovered in the Linux kernel versions used in linux-aws-5.4 and linux-hwe-5.4. These include flaws in the algif_aead cryptographic module and socket buffer handling, which could allow a local attacker to escalate privileges or escape container environments. The vulnerabilities affect several subsystems including Cryptographic API, Packet sockets, RDS protocol, and TLS protocol. Fixes are available in updated kernel versions and should be applied promptly.

References

Community reviews

Loading reviews…