Skip to main content
VulnerabilityPublished Updated

CVE-2025-38477: linux-aws-fips, linux-fips, linux-gcp-fips vulnerabilities

Affects Linux kernelSource GCVE Database

0
Compare

Mentioned vulnerabilities

Not known to be exploited · fixed in 5.15.0-1093.100+fips1 : patch Linux kernel soon.

Data as of 3 Nov 2026, 17:29 UTC

Severity
High

Rated High by Threat Radar's AI analysis · No CVSS score from NVD or the CNA

Patch
Available – fixed in 5.15.0-1093.100+fips1, 5.15.0-157.167+fips1, 5.15.0-1093.102+fips1

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 2 Oct 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Upgrade the Ubuntu to 5.15.0-1093.100+fips1 (linux-aws-fips package) or 5.15.0-157.167+fips1 (linux-fips package) or 5.15.0-1093.102+fips1 (linux-gcp-fips package).

Affected software

ProductAffectedFixed in
Ubuntu Pro FIPS-updates 22.04 LTSlinux-aws-fipspkg:deb/ubuntu/linux-aws-fips?arch=source&distro=fips-updates/jammyOther threatsAffected
  • <5.15.0-1093.100+fips1
Fixed in
  • 5.15.0-1093.100+fips1
Ubuntu Pro FIPS-updates 22.04 LTSlinux-fipspkg:deb/ubuntu/linux-fips?arch=source&distro=fips-updates/jammyOther threatsAffected
  • <5.15.0-157.167+fips1
Fixed in
  • 5.15.0-157.167+fips1
Ubuntu Pro FIPS-updates 22.04 LTSlinux-gcp-fipspkg:deb/ubuntu/linux-gcp-fips?arch=source&distro=fips-updates/jammyOther threatsAffected
  • <5.15.0-1093.102+fips1
Fixed in
  • 5.15.0-1093.102+fips1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and users should update their systems to the fixed kernel versions 5.15.0-1093.100+fips1, 5.15.0-157.167+fips1, or 5.15.0-1093.102+fips1 as provided by the Ubuntu security notice USN-7793-3. After updating, a system reboot is required to apply the fixes. Due to an ABI change, any third-party kernel modules must be recompiled and reinstalled to maintain compatibility. Following these steps will mitigate the vulnerabilities.

Description

Multiple security vulnerabilities were identified in the Linux kernel affecting the linux-aws-fips, linux-fips, and linux-gcp-fips packages. These flaws impact subsystems including packet sockets, network traffic control, and the VMware vSockets driver. An attacker could potentially exploit these issues to compromise the affected system. Fixes have been released and are available through updated kernel packages. Users must apply the updates and reboot their systems to ensure protection. Due to ABI changes, recompilation of third-party kernel modules may be required.

References

Community reviews

Loading reviews…