Skip to main content
VulnerabilityPublished Updated

CVE-2025-38561: linux-fips, linux-aws-fips, linux-gcp-fips vulnerabilities

Affects Linux kernelSource GCVE Database

0
Compare

Mentioned vulnerabilities

Not known to be exploited · fixed in 6.8.0-1045.47+fips1 : patch Linux kernel soon.

Data as of 3 Nov 2026, 17:31 UTC

Severity
High

Rated High by Threat Radar's AI analysis · No CVSS score from NVD or the CNA

Patch
Available – fixed in 6.8.0-1045.47+fips1, 6.8.0-94.96+fips1, 6.8.0-1046.49+fips1

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Upgrade the Ubuntu to 6.8.0-1045.47+fips1 (linux-aws-fips package) or 6.8.0-94.96+fips1 (linux-fips package) or 6.8.0-1046.49+fips1 (linux-gcp-fips package).

Affected software

ProductAffectedFixed in
Ubuntu Pro FIPS-updates 24.04 LTSlinux-aws-fipspkg:deb/ubuntu/linux-aws-fips?arch=source&distro=fips-updates/nobleOther threatsAffected
  • <6.8.0-1045.47+fips1
Fixed in
  • 6.8.0-1045.47+fips1
Ubuntu Pro FIPS-updates 24.04 LTSlinux-fipspkg:deb/ubuntu/linux-fips?arch=source&distro=fips-updates/nobleOther threatsAffected
  • <6.8.0-94.96+fips1
Fixed in
  • 6.8.0-94.96+fips1
Ubuntu Pro FIPS-updates 24.04 LTSlinux-gcp-fipspkg:deb/ubuntu/linux-gcp-fips?arch=source&distro=fips-updates/nobleOther threatsAffected
  • <6.8.0-1046.49+fips1
Fixed in
  • 6.8.0-1046.49+fips1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and users should update their Linux kernel packages to the fixed versions 6.8.0-1045.47+fips1, 6.8.0-94.96+fips1, or 6.8.0-1046.49+fips1 as appropriate. After updating, a system reboot is required to apply the changes. Due to an ABI change, all third-party kernel modules must be recompiled and reinstalled. Follow the official Ubuntu security notice USN-8015-3 for detailed update instructions.

Description

Multiple security vulnerabilities were discovered in the Linux kernel affecting the Cryptographic API, SMB network file system, and io_uring subsystem. These flaws could potentially allow an attacker to compromise the system. Fixes have been released in updated Linux kernel packages for various FIPS-certified builds, including those for AWS and GCP environments. Users must apply these updates and reboot their systems to ensure protection. Due to ABI changes, recompilation of third-party kernel modules is required after updating.

References

Community reviews

Loading reviews…