Skip to main content
VulnerabilityPublished Updated

CVE-2025-54518: linux-aws, linux-raspi vulnerabilities

Affects Linux kernelSource GCVE Database

0
Authoritative record:CVE-2025-54518· High 7.3

Not known to be exploited · CVSS 7.3 High · fixed in 7.0.0-1009.9 : patch Linux kernel soon.

Data as of 28 Oct 2026, 03:31 UTC

CVSS 4.0 base score
7.3High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 7.0.0-1009.9, 7.0.0-1015.15
CVSS:4.0/AV:L/AC:H/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 15 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade the Ubuntu to 7.0.0-1009.9 (linux-aws package) or 7.0.0-1015.15 (linux-raspi package).

Affected software

ProductAffectedFixed in
Ubuntu 26.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1009.9
Fixed in
  • 7.0.0-1009.9
Ubuntu 26.04 LTSlinux-raspipkg:deb/ubuntu/linux-raspi?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1015.15
Fixed in
  • 7.0.0-1015.15

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied to affected systems. The fixed versions include 7.0.0-1009.9 and 7.0.0-1015.15. Users should update to these or later versions to remediate the vulnerabilities. Refer to the official Ubuntu security notice USN-8618-1 for detailed patch information. No additional mitigation actions are indicated beyond applying the official fixes.

Description

Multiple security vulnerabilities were discovered in the Linux kernel affecting numerous subsystems and architectures, including a specific issue in AMD Zen 2 processors where shared resources in the operation cache were not properly isolated. This could allow a local attacker to corrupt instructions executed at a higher privilege level, potentially leading to privilege escalation. The update addresses flaws across a wide range of kernel components and drivers.

References

Community reviews

Loading reviews…