CVE-2025-37756: linux-azure-6.8 vulnerabilities
Affects Linux kernelSource GCVE Database
Not known to be exploited : upgrade to 6.8.0-1040.46~22.04.1 soon.
Data as of 31 Oct 2026, 01:28 UTC
Rated High by Threat Radar's AI analysis · No CVSS score from NVD or the CNA
- Patch
- Available – fixed in 6.8.0-1040.46~22.04.1
Exploitation evidence
Disclosed: evidence found.
CVE published 14 Oct 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade the Ubuntu linux-azure-6.8 package to 6.8.0-1040.46~22.04.1.
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 22.04 LTSlinux-azure-6.8pkg:deb/ubuntu/linux-azure-6.8?arch=source&distro=jammyOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Apply the security update provided by Ubuntu (linux-azure-6.8 version 6.8.0-1040.46~22.04.1 or later) as soon as possible. After updating, reboot the system to activate the fixes. Recompile and reinstall any third-party kernel modules due to the ABI change introduced by this update. Follow the official Ubuntu security notice USN-7808-2 for detailed instructions.
Description
Multiple security vulnerabilities were identified in the Linux kernel for the Azure platform, affecting various subsystems including network drivers, file systems, and protocol implementations. These flaws could potentially allow an attacker to compromise the system. A security update addressing these issues has been released and requires a system reboot and recompilation of third-party kernel modules due to ABI changes.
References
- ubuntu.com/security/notices/USN-7808-2 (opens in a new tab)
- ubuntu.com/security/CVE-2025-37756 (opens in a new tab)
- ubuntu.com/security/CVE-2025-37785 (opens in a new tab)
- ubuntu.com/security/CVE-2025-38244 (opens in a new tab)
- ubuntu.com/security/CVE-2025-38477 (opens in a new tab)
- ubuntu.com/security/CVE-2025-38500 (opens in a new tab)
- ubuntu.com/security/CVE-2025-38617 (opens in a new tab)
- ubuntu.com/security/CVE-2025-38618 (opens in a new tab)
- ubuntu.com/security/CVE-2025-38683 (opens in a new tab)