Skip to main content
VulnerabilityPublished Updated

CVE-2025-38477: linux-azure-fips vulnerabilities

Affects Linux kernelSource GCVE Database

0
Compare

Not known to be exploited : upgrade to 5.15.0-1097.106+fips1 soon.

Data as of 3 Nov 2026, 17:44 UTC

Severity
High

Rated High by Threat Radar's AI analysis · No CVSS score from NVD or the CNA

Patch
Available – fixed in 5.15.0-1097.106+fips1

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 Oct 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Upgrade the Ubuntu linux-azure-fips package to 5.15.0-1097.106+fips1.

Affected software

ProductAffectedFixed in
Ubuntu Pro FIPS-updates 22.04 LTSlinux-azure-fipspkg:deb/ubuntu/linux-azure-fips?arch=source&distro=fips-updates/jammyOther threatsAffected
  • <5.15.0-1097.106+fips1
Fixed in
  • 5.15.0-1097.106+fips1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Apply the official security update provided by Ubuntu in package version 5.15.0-1097.106+fips1 or later. After updating, reboot the system to activate the fixes. Due to an ABI change, recompile and reinstall all third-party kernel modules. Standard system upgrades will handle this automatically unless kernel metapackages were manually removed.

Description

Multiple security vulnerabilities were identified in the Linux kernel for the Azure FIPS variant, affecting network drivers, packet sockets, network traffic control, and the VMware vSockets driver. These flaws could potentially allow an attacker to compromise the system. A security update addressing these issues is available and requires a system reboot and recompilation of third-party kernel modules due to an ABI change.

References

Community reviews

Loading reviews…