Skip to main content
VulnerabilityPublished Updated

CVE-2025-10263: linux-fips vulnerabilities

Affects Linux kernelSource GCVE Database

0
Compare
Authoritative record:CVE-2025-10263· Critical 9.1

Not known to be exploited · CVSS 9.1 Critical : upgrade to 5.15.0-194.204+fips1 as a priority.

Data as of 6 Nov 2026, 14:52 UTC

CVSS 3.1 base score
9.1Critical
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 5.15.0-194.204+fips1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 9 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.

What to do

Upgrade the Ubuntu linux-fips package to 5.15.0-194.204+fips1.

Affected software

ProductAffectedFixed in
Ubuntu Pro FIPS-updates 22.04 LTSlinux-fipspkg:deb/ubuntu/linux-fips?arch=source&distro=fips-updates/jammyOther threatsAffected
  • <5.15.0-194.204+fips1
Fixed in
  • 5.15.0-194.204+fips1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and has been released by Ubuntu in the linux-fips kernel packages (version 5.15.0-194.204+fips1 and later). Users should update their systems to these fixed versions and reboot to apply the changes. Due to ABI changes, all third-party kernel modules must be recompiled and reinstalled after the update. Following the vendor's update instructions will mitigate these vulnerabilities.

Description

Multiple security vulnerabilities were discovered in the Linux kernel, including a critical issue affecting some Arm processors where a broadcast TLB invalidation could complete before memory writes were globally observed. This flaw could allow a local attacker to write to memory after permissions were revoked, potentially bypassing memory protections or escalating privileges. The update addresses these issues across various subsystems such as ARM64 architecture, InfiniBand, network drivers, file systems, and networking protocols. A patch is available and should be applied to mitigate these vulnerabilities.

References

Community reviews

Loading reviews…