CVE-2025-38350: linux-gcp-6.14, linux-oracle, linux-oracle-6.14 vulnerability
Affects Linux kernelSource GCVE Database
Not known to be exploited · fixed in 6.14.0-1015.16~24.04.1 : patch Linux kernel soon.
Data as of 3 Nov 2026, 17:44 UTC
Rated High by Threat Radar's AI analysis · No CVSS score from NVD or the CNA
- Patch
- Available – fixed in 6.14.0-1015.16~24.04.1, 6.14.0-1012.12~24.04.1
Exploitation evidence
Disclosed: evidence found.
CVE published 17 Sep 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.
What to do
Upgrade the Ubuntu to 6.14.0-1015.16~24.04.1 (linux-gcp-6.14 package) or 6.14.0-1012.12~24.04.1 (linux-oracle-6.14 package).
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 24.04 LTSlinux-gcp-6.14pkg:deb/ubuntu/linux-gcp-6.14?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-oracle-6.14pkg:deb/ubuntu/linux-oracle-6.14?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and users should update their systems to the fixed kernel versions 6.14.0-1015.16~24.04.1 or 6.14.0-1012.12~24.04.1 as provided by Ubuntu security notices. After updating, a system reboot is required to apply the changes. Due to an ABI change, recompilation and reinstallation of any third-party kernel modules is necessary. Standard system upgrades will handle this automatically unless kernel metapackages were manually removed.
Description
A security vulnerability was discovered in the Linux kernel affecting the network traffic control subsystem. This flaw could potentially allow an attacker to compromise the system. The issue affects Linux kernel versions prior to 6.14.0-1015.16~24.04.1 and 6.14.0-1012.12~24.04.1. A patch is available and has been released by Ubuntu for the affected kernel packages. Users are advised to update and reboot their systems to apply the fix.