CVE-2025-38003: linux, linux-aws, linux-gcp, linux-gcp-6.14, linux-oracle, linux-realtime vulnerabilities
Affects Linux kernelSource GCVE Database
Not known to be exploited : upgrade to 6.14.0-1016.17~24.04.1 soon.
Data as of 3 Nov 2026, 17:28 UTC
Rated High by Threat Radar's AI analysis · No CVSS score from NVD or the CNA
- Patch
- Available – fixed in 6.14.0-1016.17~24.04.1
Exploitation evidence
Disclosed: evidence found.
CVE published 8 Jun 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.
What to do
Upgrade the Ubuntu linux-gcp-6.14 package to 6.14.0-1016.17~24.04.1.
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 24.04 LTSlinux-gcp-6.14pkg:deb/ubuntu/linux-gcp-6.14?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and should be applied by updating to Linux kernel version 6.14.0-1016.17~24.04.1 or later as provided by the Ubuntu security notice USN-7769-1. After updating, a system reboot is required to activate the fixes. Due to an ABI change, all third-party kernel modules must be recompiled and reinstalled. Users should follow standard update procedures for their distribution to ensure all kernel packages are updated accordingly.
Description
Multiple security vulnerabilities were discovered in the Linux kernel affecting numerous subsystems and architectures. These issues could potentially allow an attacker to compromise the system. The vulnerabilities impact a wide range of components including CPU architectures (ARM64, PowerPC, x86), device drivers, filesystems, networking stacks, and various kernel subsystems. A patch has been released to address these flaws in the Linux kernel version 6.14.0-1016.17~24.04.1 for the linux-gcp-6.14 package and related kernels.
References
- ubuntu.com/security/notices/USN-7769-1 (opens in a new tab)
- ubuntu.com/security/CVE-2025-38003 (opens in a new tab)
- ubuntu.com/security/CVE-2025-38004 (opens in a new tab)
- ubuntu.com/security/CVE-2025-38029 (opens in a new tab)
- ubuntu.com/security/CVE-2025-38031 (opens in a new tab)
- ubuntu.com/security/CVE-2025-38032 (opens in a new tab)
- ubuntu.com/security/CVE-2025-38033 (opens in a new tab)
- ubuntu.com/security/CVE-2025-38034 (opens in a new tab)
- ubuntu.com/security/CVE-2025-38035 (opens in a new tab)
- ubuntu.com/security/CVE-2025-38036 (opens in a new tab)
- ubuntu.com/security/CVE-2025-38037 (opens in a new tab)
- ubuntu.com/security/CVE-2025-38038 (opens in a new tab)
- ubuntu.com/security/CVE-2025-38039 (opens in a new tab)
- ubuntu.com/security/CVE-2025-38040 (opens in a new tab)
- ubuntu.com/security/CVE-2025-38041 (opens in a new tab)
- ubuntu.com/security/CVE-2025-38042 (opens in a new tab)
- ubuntu.com/security/CVE-2025-38043 (opens in a new tab)
- ubuntu.com/security/CVE-2025-38044 (opens in a new tab)
- ubuntu.com/security/CVE-2025-38045 (opens in a new tab)
- ubuntu.com/security/CVE-2025-38047 (opens in a new tab)